forex software

Create and Test Forex Strategies

forex software

eas-guide:data-import

Data Import

EA Studio provides an easy way to upload your own history data for backtesting. It is very important to create and test your strategies on data from the broker you will use later for trading. The different brokers have different data providers and time zones. If you use different data it very likely that the tests in EA Studio and MetaTrader will not match.

Data export scripts

In the Data Import page we provide two Data Export Scripts (MQL). One for MetaTrader 4 and one for MetaTrader 5.

Here is how to install a data import script in MetaTrader:

  1. Download the script for your version of MetaTrader
  2. Go to File > Open Data Folder
  3. From the list open the MQL4 folder
  4. Open the Scripts folder
  5. Put the downloaded file in the current (Scripts) folder
  6. Go back to MetaTrader
  7. Go to the Navigator box (if it is not open open it from View > Navigator)
  8. Right click in the Navigator box and use Refresh from the menu.
  9. The script will appear in the list.
  10. The below steps are only needed for MT5 since it does not compile new scripts automatically.
  11. In the Navigator box right-click on the script name and choose Modify
  12. A code editor will open. From the buttons in the top menu click Compile
  13. Close the code editor window.

The end result should look like this:

Data export script

Export Files from MetaTrader

  1. Open a chart
  2. Disable auto-scrolling on new tick (See Disabling auto-scroll on new tick below)
  3. Use Ctrl + - to zoom out the chart so more bars can be loaded at once
  4. Press the Home key on your keyboard as long as new bars appear to the left (this and the previous one allow you to load all bars your broker would send to your MetaTrader)
  5. Drag and drop the Script to the chart. If everything works OK you should see messages on the chart similar to Working script (see below)

Disabling auto-scroll on new tick

Disabling auto-scroll on new tick

Working script

Exported files

Import Files to EA Studio

The Script will save all data files to the MetaTrader MQL*/Files folder. To import the files to EA Studio

  1. Go to File > Open Data Folder
  2. From the list open the MQL4 folder
  3. Open the Files folder. You should see multiple JSON files in it. Select all files and drag and drop them to EA Studio

The program will show the list of the loaded files.

You can return in the Editor page and to select your data server and symbols. If you are signed in, the application will store the files on the cloud.