Topic: Browser Slowdowns the Inactive Tabs

Hi,

i dont know why but something has changed.

My workflow was open some Tabs put in in a 2nd 3rd Desktop and let eas run.

No it is impossible to let it run in 2nd and 3rd Desktop. Seems that eas have to be active in Front.

Can someone have the same right now ?

2 (edited by Bigricky1 2020-10-24 00:56:18)

Re: Browser Slowdowns the Inactive Tabs

Yes.  I have the same problem....  Something has changed.....  Started doing it 2 days ago or so.....  I haven't done an update on chrome or windows so I don't think it is that.....

Re: Browser Slowdowns the Inactive Tabs

same to me

4 (edited by montreal06 2020-10-29 18:39:39)

Re: Browser Slowdowns the Inactive Tabs

Hi guys,

I had the same problem. I found the solution.


Solution

Use Edge. Edge and Chrome are based on the Chromium browser.

Edge does not stall whether you put in another desktop or close your RDP connection to your personal server.

Re: Browser Slowdowns the Inactive Tabs

Hi all,

My Edge has now begun to do the same - anybody else have the same problem?

Re: Browser Slowdowns the Inactive Tabs

There was a bigger chrome update couple of days ago, seems significant.

Re: Browser Slowdowns the Inactive Tabs

Yes same here....  I have 2 PCs.  The one that does not allow any updates is fine.  The one that updated is now affected.  I have tried uninstalling updates and even rolling my PC back to previous restore points.  Microsoft will not allow you to remove updates from Edge.  Anyone else have similar problems and any answers......  This is becoming a pain in the ASS.........

Re: Browser Slowdowns the Inactive Tabs

If it is all about browser behaviour, then it's looking bad because it's out of developer's hands. I'll try to get some more info about this.

There's a workaround of sorts... Remove the browser completely and install an older version with updating turned off. I know I had hard time doing that to chrome couple of years ago, with the newest version it might be even harder, I swear google is worse than gestapo.

Re: Browser Slowdowns the Inactive Tabs

I have now for a few hours run four sessions of Reactor on each their virtual desktop. I use the Opera browser and they all run continuously in parallel. The browser has version no. 72.0.3815.378. If Opera also gets into the same problems as Edge and Chrome in the future, I can see that at www.opera.com/download and at the very bottom of the page there is an archived with former versions of Opera, so it should be possible to find one previous version which hopefully can run multiple Reactor's at the same time.

Re: Browser Slowdowns the Inactive Tabs

Hi all,



Here are two solutions:

1) Those with 2 pcs. Do not use RDP (Microsoft's Remote Desktop method). Use VNC to remote into your personal PC. You can use Edge or Chrome


2) Both Edge and Chrome have been updated. However, you can retrieve the stable version of Chromium which Edge and Chrome use to develop their browser like the steps below:

Lastly, download Chromium and install.


There you go! Two solutions.

11 (edited by Roughey 2020-12-08 22:01:57)

Re: Browser Slowdowns the Inactive Tabs

thats not good...edge the same now...any solutions

Re: Browser Slowdowns the Inactive Tabs

Yes we are running out of options.  I could not get any edge / chromium ones to work.  Only solution so far for me is firefox......

Re: Browser Slowdowns the Inactive Tabs

hey boys n girls ;-)

i have a solution..

it looks very fast i have downloaded a portable version of chrome.

https://nav.dl.sourceforge.net/project/crportable/ChromiumPortable_61.0.3153.0.paf.exe

Re: Browser Slowdowns the Inactive Tabs

ok let it run one day all 3 tabs were crashed so its not a solution...

Re: Browser Slowdowns the Inactive Tabs

just check out now this browser. looks good for right now.

https://www.opera.com/de/gx

but problem here after closing tab. settings from before are not saved.

Re: Browser Slowdowns the Inactive Tabs

What you need to do is change some settings in Chrome to disable throttling of non-active windows.

Go to the address bar in Chrome and type Chrome://flags

This will bring you to the window shown below.  It will warn you the stuff is experimental and such.   In the Search bar type "Throttle" and it will bring up a few options, where you can choose to disable them.

Select Throttle Javascript timers in background, and Calculate window occlusion on Windows, and change the option from Default to Disabled.

Click on Relaunch.

After this, when you open multiple Chrome Windows (not tabs), and even if they are hidden behind the front active window all run at the full speed.  This way I have opened 20-40 windows all processing simultaneously on my Ryzen 5950X based computer.

Hope this is helpful.

Chris

Post's attachments

chrome flags throttle.jpg 72.15 kb, 1 downloads since 2021-01-27 

You don't have the permssions to download the attachments of this post.

Re: Browser Slowdowns the Inactive Tabs

You can assure yourself that you are maxing out your processor by hitting Ctrl-Alt_del to bring up Task Manager, then clicking on the "Performance" tab, wich will show you your CPU utilization.

If you see only one graph, Right click anywhere on the graph and select Change Graph to....
Logical Processors.

This will show you the usage inidividually of the number of logical threads you have in your CPU.  Like you see here in my attached picture.  I have 4 Cores with 2 threads each on this current computer (my office one, not the Ryzen one).

Chris

Post's attachments

logical processors.jpg
logical processors.jpg 77.69 kb, 2 downloads since 2021-01-27 

You don't have the permssions to download the attachments of this post.

Re: Browser Slowdowns the Inactive Tabs

Excellent job toffidoc!

Re: Browser Slowdowns the Inactive Tabs

toffidoc wrote:

What you need to do is change some settings in Chrome to disable throttling of non-active windows.

Go to the address bar in Chrome and type Chrome://flags

This will bring you to the window shown below.  It will warn you the stuff is experimental and such.   In the Search bar type "Throttle" and it will bring up a few options, where you can choose to disable them.

Select Throttle Javascript timers in background, and Calculate window occlusion on Windows, and change the option from Default to Disabled.

Click on Relaunch.

After this, when you open multiple Chrome Windows (not tabs), and even if they are hidden behind the front active window all run at the full speed.  This way I have opened 20-40 windows all processing simultaneously on my Ryzen 5950X based computer.

Hope this is helpful.

Chris


20-40 chrome tabs??wtf. i can make 6 and when i look on next day 3 are crashed with ryzen 5 1600 sixcore...

Re: Browser Slowdowns the Inactive Tabs

Roughey,

No kidding.........here in the attached screenshot you'll see 20 Chrome windows open simultaneously.  I have got 16x2=32 Logical processors.  I'm calculating H4 strategies and my CPU % usage is around 35%.  So it is possible to open many more Chrome windows than I currently have.

Post's attachments

20 Chrome instances.jpg 299.33 kb, file has never been downloaded. 

You don't have the permssions to download the attachments of this post.

Re: Browser Slowdowns the Inactive Tabs

Thanks for this Toffidoc......  This has been a pain in the ass for a while......

Re: Browser Slowdowns the Inactive Tabs

Bigricky1 wrote:

Thanks for this Toffidoc......  This has been a pain in the ass for a while......

Most welcome.  Just trying to give back to this community as I've learnt quite a lot from here.

Re: Browser Slowdowns the Inactive Tabs

Thanks Toffidoc, this is very helpful

Re: Browser Slowdowns the Inactive Tabs

toffidoc wrote:

Roughey,

No kidding.........here in the attached screenshot you'll see 20 Chrome windows open simultaneously.  I have got 16x2=32 Logical processors.  I'm calculating H4 strategies and my CPU % usage is around 35%.  So it is possible to open many more Chrome windows than I currently have.


ok h4 strategies..it depends on how many bars you have loaded. when you use 200000 bars you never get more than 3 when you dont want to risk crash .