forex software

Create and Test Forex Strategies

forex software

Skip to forum content

Forex Forum

Forex Software, Forex Strategies, Expert Advisors Generator

You are not logged in. Please login or register.


Forex Forum → Help and Support → Some symbols not working

Pages 1

You must login or register to post a reply

RSS topic feed

Posts: 17

Topic: Some symbols not working

Hello, I am trying the program, I exported more than 15 symbols according to video tutorials, including their historical data, but when I am on the editor adding some indicators for elaborating a strategy, some symbols work just fine, and FSB can display the chart indicating the account balance, but wiith some other symbols no matter the indicator I use, it displays a flat line (like there is no indicator at all), also the generator is unable to create a strategy...
As far as I know, i repeated all the process correctly on every symbol:
use trader mode on FSB, and in MT4 put MT4 bridge on every symbol, then get historical data from every symbol in all time frames.

I don't know what I am doing wrong.

Please help, and thanks in advance.

Divarak

Re: Some symbols not working

Can you post an image of the Editor page and Symbols page?

If FSB Pro can load the data it can make a strategy for it.

Re: Some symbols not working

Sure! here it goes! (not working)

https://s31.postimg.org/3ksw82p9j/FSB_not_working.jpg

Re: Some symbols not working

This is with a symbol that works

https://s31.postimg.org/rd27jlraf/FSB_working.jpg

Re: Some symbols not working

And this is my symbols setting.
Sorry for my terrible internet habilities... Couldn´t manage to send all images in one post. sad

https://s31.postimg.org/s3uxpdtnr/symbols.jpg

Re: Some symbols not working

Lets concentrate on non-working symbol, can you make a scshot of CHFJPY symbol settings? And how the indicator chart looks like?

Re: Some symbols not working

Here they are.
https://s32.postimg.org/d9884jaf5/chfjpy_indicator.jpg

https://s32.postimg.org/ckzdllbpd/chfjpy_symbol.jpg

Re: Some symbols not working

Probably your first strategy doesn't trade because the "Forming MA Period" of AC is equal to 1 and the indicator doesn't allows entries.

Your last strategy does't trade because the entry conditions doesn't clearly define the entry. I see all bars are ambiguous.

It is clear that these screenshot show different strategies.

It looks like the problem is in the strategy parameters instead in the loaded data. You can easily check that by loading one of the demo strategies provided with the software on the data you imported.

If you still have problems please post the concrete strategy and a screenshot of the editor page that shows both input and output info tables.

Re: Some symbols not working

Mr. Popov, maybe I´m not expaining myself clearly...
No matter the strategy I use, when I choose a specific symbol (like CHFJPY), I can´t get any results... I also get running the Generator over 4 hours on a i7-2600K, with no results, the generator get anything!
On Output log returns "Data check warning, see data statistic... " When I check CHFJPY M15 it says "Bar gaps filled in.
Big Range of bar 10018 at 2016-06-24 05:30."

I tried "Demo MACD Reversal", the behavior still the same

I loaded "Maxmillion GBPUSD from Repository", on GBPUSD, there is a chart on Balance/Equity, but when I choose CHFJPY, again I have a straight line...
Here goes the screenshots.
I already throw away my historical data and re-created it again from my MT4 Terminal.



https://s31.postimg.org/htbh5kx3b/million1.jpg

https://s31.postimg.org/65hfb17yf/million2.jpg

Re: Some symbols not working

This is strange.

Can you attach this file to the forum?

Re: Some symbols not working

This file? I assume you want the strategy hmm
Here I atattch the one for the original symbol, and with the problematic one....

By the way.... Is there a way to be sure that in the historical data there are no inconsistencies?

Post's attachments

fsb_sym.zip 5.69 kb, 1 downloads since 2016-07-18 

You don't have the permssions to download the attachments of this post.

Re: Some symbols not working

Excuse me, I missed to note that I want to test your your CHFJPY15.csv file. Can you attach it?

Re: Some symbols not working

Here´s the file.

Post's attachments

CHFJPY15.zip 140.16 kb, 1 downloads since 2016-07-19 

You don't have the permssions to download the attachments of this post.

Re: Some symbols not working

I am also having problems with my second account, here´s the file of that account.

Re: Some symbols not working

The file... hmm

Post's attachments

CHFJPY15_second account.zip 81.7 kb, 1 downloads since 2016-07-19 

You don't have the permssions to download the attachments of this post.

Re: Some symbols not working

Here is a solution:

1. Go to the Control Panel -> Account page
2. Set the Active profile and Data Source if it is necessary (it is not in your case)
3. Click "Update"

The program will update the Account Exchange rates from internet.

http://s32.postimg.org/o05epszut/screenshot_1920.png


Restart FSB Pro.

It must work then:

http://s32.postimg.org/6o524d6dh/screenshot_1921.png

Re: Some symbols not working

Now we‘re talking! (like Americans say).
Now it`s working!. Thank you! big_smile

Posts: 17

Pages 1

You must login or register to post a reply

Forex Forum → Help and Support → Some symbols not working

Similar topics in this forum