Topic: Can`t load enough bars

Hello
i'm testing my first EA and i get these error messages:
i have historical data from 2003 since 2017, and i have selected 2014-2016 period for the test.

ERROR 1:
2017.08.17 18:09:18.258    2014.01.02 00:00:58  Strategy EURUSD,H1:
Cannot load enough bars! The expert needs minimum 122 bars.
Please check the "Use date" option and set the "From:" and "To:" dates properly.

ERROR 2:
2017.08.17 18:09:18.258    2014.01.02 00:00:58  Strategy EURUSD,H1: LabelDelete: failed to delete a text label! Error code = 4202

Please, i appreciate your help.

Re: Can`t load enough bars

Scroll to to the start of your data series in the MT chart to see from where the data starts. Than add about two weeks to that time and set it as a starting time in the MetaTrader tester.

You can also try to set the last month only for a fast test.

Re: Can`t load enough bars

Thanks Popov. As i tried to explain in the message, I have historical data since 2003, and the start backtest data is set to 2014, so enough bars for the EA.

Re: Can`t load enough bars

Please attach the expert for inspection.

Re: Can`t load enough bars

Popov wrote:

Please attach the expert for inspection.

Post's attachments

Strategy.ex4 281.05 kb, 3 downloads since 2017-08-19 

You don't have the permssions to download the attachments of this post.

Re: Can`t load enough bars

It works like  a charm.

https://s3.postimg.org/nl7lbjazn/screenshot_402.png

Re: Can`t load enough bars

Thnaks Popov. I'm using tick data suite, and that's the reason the EA is not working for me. If i don't use it, works fine.

Re: Can`t load enough bars

I have not found the need to use tick data suite with FSBPro.

My 'secret' goal is to push EA Studio until I can net 3000 pips per day....