1 (edited by geektrader 2010-04-19 04:43:07)

Topic: Can´t raise lot-size above 0.00

I have a really strange problem with Forex Strategy Trader.

I can´t change the lot-size higher than 0.00 and hence can´t execute any trades. In the "Operation"-Tab, as long as Metatrader is NOT running, I can raise the lot-size to whatever I like, but once FST is connected with MetaTrader, the lot-size can´t be raised any higher than 0.00.

Also any strategy that I start for auto-trading executes Buys/Sells with "0.00" lots and hence MetaTrader raises an error, telling that the specified lot-size is not correct, although I´ve also set it to "1.00" in the strategy-properties. Really strange.

I have enough funds in my account and manual trading directly in Metatrader also works fine with 1 lot. But with Forex Strategy Trader, regardless what I do and regardless if I want to buy/sell manually or let a strategy run automatically, it doesn´t go above a 0.00 lot-size and hence doesn´t trade anything:(

Does anyone know how to fix this strange problem?

Thanks a lot!


Re: Can´t raise lot-size above 0.00

I really need to start trading this strategy but still can´t get buy/sell orders from FST with a lot-size higher than 0.00. I have tried everything I could, nothing helps, I can change the lot-size in FST fine as long as the EA is not connected, but once connected, lot-size jumps to 0.00 and can´t be raised anymore. Everything else is absolutely fine with FST/MetaTrader, it even executes the trades of my strategy, but tries that with a lot-size of 0.00 as well and hence Metatrader raises an error. I have set the correct lot-size in the strategy-settings, but I guess there it is the same problem as with the manual trading in FST were I also can´t change the lot-size above 0.00.

If anyone can help me with this quickly I would be willing to pay him/her as I can´t reach Popov neither via email nor through the forum.

Thanks a lot.

Re: Can´t raise lot-size above 0.00

After hours of searching I seem to have found the problem. My broker (ActivTrades), does report several fields of the Market Info with "0". Including the Min AND Max Lot Size, both are being displayed as "0".


To make things work correctly, I have to edit the Expert Advisor and replace ALL those lines with the following (Use "Replace" from the Edit Menu in MetaEditor), without the quotes:

"MarketInfo(symbol, MODE_MINLOT)" -> "0.10"
"MarketInfo(symbol, MODE_MAXLOT)" -> "20.00"
"MarketInfo(symbol, MODE_LOTSTEP)" -> "0.10"

Now things are working fine for me and FST is trading!! I hope this get´s fixed in future releases of FST for wrong-reporting-brokers like ActivTrades seems to be one.

Re: Can´t raise lot-size above 0.00

Update: I´ve reported the issue to ActivTrades as well since if they would correctly specify those values, FST would have worked out of the box for me as well. Hope they fix it to the correct values soon.

Re: Can´t raise lot-size above 0.00

I'm glad to see you have fixed the problem in a proper way. This must be a serious issue for ActivTrades.
Please post their response to your question.